Advisory: Potential Microsoft 365 Access Issues in Chrome

Incident Report for CU Anschutz ISS and CU Denver OIT

Resolved

This incident has been resolved.
Posted Apr 17, 2026 - 09:03 MDT

Investigating

Microsoft is investigating an issue with accessing some web-based Microsoft 365 services when using the latest version of Google Chrome. They are currently taking action to address the problem.
Posted Apr 16, 2026 - 12:07 MDT
This incident affected: Email.