Call Center Phones

Incident Report for CU Anschutz ISS and CU Denver OIT

Resolved

The fix implemented by Lumen resolved this outage: campus phones are fully operational.
Posted Jan 30, 2026 - 15:44 MST

Monitoring

Campus phone services, including the Lumen-impacted calls from outside the campus, appear to operating normally at this time. ISS will continue to monitor this service.
Posted Jan 30, 2026 - 12:54 MST

Identified

The issue has been identified as a vendor (Lumen) outage and the vendor has confirmed that they are working towards resolution,
Posted Jan 30, 2026 - 12:36 MST

Investigating

Phone services involving inbound calls from off campus may be unavailable for some users, investigation is in process
Posted Jan 30, 2026 - 09:35 MST
This incident affected: Telephone Services (CU Anschutz, CU Denver).