Network issues reported on CUAnschutz and CUDenver.

Incident Report for CU Anschutz ISS and CU Denver OIT

Resolved

This incident has been resolved.
Posted Apr 16, 2026 - 06:58 MDT

Monitoring

The downstream internet provider had some issues which they have corrected. This issue effected many users in the Denver area.
Posted Apr 15, 2026 - 18:03 MDT

Update

Slow network speeds. Networking anomalies from users on both campuses. Reports of wireless and wired connections. #519802
Posted Apr 15, 2026 - 17:39 MDT

Investigating

ISS is investigating the issue.
Posted Apr 15, 2026 - 17:24 MDT
This incident affected: Network Services (CU Anschutz, CU Denver).