CU South School of Nursing Power Outage

Incident Report for CU Anschutz ISS and CU Denver OIT

Monitoring

Information Strategy and Services (ISS) has identified the cause of the service disruption.

What service is affected: Power service to the CU South building

What fix has been applied: Xcel has restored service

Workarounds (if any):

ISS will continue to monitor the service for full stability and service restoration.

Incident: 3089216
Posted Sep 11, 2026 - 10:31 MDT

Update

Information Strategy and Services (ISS) has identified the cause of the service disruption and is working on a resolution.

What service is affected: Power disruption causing all building services to be offline.

What is the issue: Xcel has identified that there is a service disruption in the area.

Who is impacted: All occupants of CU South building.

Workarounds (if any): none

Xcel has posted an estimated time for service restoration of 11:30

Thank you for your patience while our team works on resolving this as quickly as possible.

Incident: 3089216
Posted Sep 11, 2026 - 09:16 MDT

Identified

Information Strategy and Services (ISS) has identified the cause of the service disruption and is working on a resolution.

What service is affected: Power disruption causing all building services to be offline.

What is the issue: Xcel has identified a service disruption in the area

Who is impacted: All occupants of the CU South

Workarounds (if any):

Thank you for your patience while our team works on resolving this as quickly as possible.

Incident:
Posted Sep 11, 2026 - 09:04 MDT

Investigating

It appears that there may be a power outage at CU South location. Computer networks are down as well as other services in the building.
Posted Sep 11, 2026 - 08:51 MDT
This incident affects: Network Services (Off-Site Location) and Other Systems and Services.