Lowry Clinic Network Communication Outage

Incident Report for CU Anschutz ISS and CU Denver OIT

Resolved

Power has been restored and this incident has been resolved.
Posted Apr 28, 2026 - 12:56 MDT

Identified

ISS has determined that power issues on site are causing the network connectivity problems at the Lowry Medical Plaza Clinic.
Posted Apr 28, 2026 - 12:41 MDT

Investigating

ISS is troubleshooting a problem with network communication at the Lowry clinic.
Posted Apr 28, 2026 - 11:48 MDT
This incident affected: Network Services (Off-Site Location).