Imagicle eFax Service Unavailable

Incident Report for CU Anschutz ISS and CU Denver OIT

Resolved

The issues with this e-fax service have been resolved. Ticket #504986.
Posted Feb 12, 2026 - 16:03 MST

Monitoring

A fix has been implemented and ISS personnel are monitoring the results. Ticket #504986.
Posted Feb 12, 2026 - 13:13 MST

Investigating

ISS personnel are investigating an issue with Imagicle eFax. Users of this e-fax service are unable to send or receive faxes. Traditional fax machines are not impacted. An update will be posted once the root cause is identified or a fix has been implemented. Ticket #504986.
Posted Feb 12, 2026 - 12:55 MST
This incident affected: Telephone Services (CU Anschutz, CU Denver, Off-Site Location).