At noon today, Microsoft issued an updated concerning implementation of a solution for standing Teams Calling issues. As of now, ISS has received no reports of failures in Teams Calling for CU Denver or CU Anschutz campuses. This issue has been resolved.
Posted Dec 22, 2025 - 12:33 MST
Update
Microsoft's reported issues have expanded in scope. Teams issues may now be affecting the utilization of chat sessions, calling, and loading of images. ISS continues to monitor Microsoft efforts in this area but most events seem to be self-healing and ISS has yet to experience any persistent user-affecting issues.
Posted Dec 19, 2025 - 14:08 MST
Identified
Microsoft has reported a service degradation concerning Teams Calling. ISS is experiencing difficulty in adding new Teams Calling users. ISS has recorded no other issues affecting CU constituents, but current users may see a loss of dialpad access, and issues receiving calls from non-Teams phone service. Please report any issues you may experience directly to the ISS Service Desk. Major Incident 493925.
Posted Dec 19, 2025 - 10:23 MST
This incident affected: Telephone Services (CU Anschutz, CU Denver, Off-Site Location).