Cisco Finesse call center experiencing problems

Incident Report for CU Anschutz OIT | CU Denver OIT

Resolved

This incident has been resolved.
Posted Aug 20, 2025 - 18:34 MDT

Update

After the restart some users are still experiencing problems. ISS is continuing to investigate.
Posted Aug 20, 2025 - 13:57 MDT

Identified

At 12:15pm ISS will be restarting the services for this system. Users may experience a brief interrupation in services during this emergency maintenance activity.
Posted Aug 20, 2025 - 10:55 MDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 20, 2025 - 08:55 MDT

Investigating

Some users are experiencing problems logging into Cisco Finesse call center and are not able to receive phone calls. ISS is currently investigating.
Posted Aug 20, 2025 - 08:36 MDT
This incident affected: Telephone Services (CU Anschutz, CU Denver).