Service Disruption: Power Outage on Anschutz Campus Networks may be down.

Incident Report for CU Anschutz ISS and CU Denver OIT

Update

ISS has identified the cause of the service disruption.

What service is affected: Network access at various locations on campus

What fix has been applied: Power has been restored and affected hardware has been restarted.

Workarounds (if any):

ISS will continue to monitor the service for full stability and service restoration.

Incident: MI 3074256
Posted Jul 05, 2026 - 13:01 MDT

Update

We are continuing to monitor for any further issues.
Posted Jul 05, 2026 - 13:00 MDT

Monitoring

ISS has identified the cause of the service disruption.

What service is affected: Anchutz campus networks in various building have been unavailable.

What fix has been applied: Power has been restored and hardware that was affected has been restarted

Workarounds (if any):

ISS will continue to monitor the service for full stability and service restoration.

Incident: MI 3074256
Posted Jul 05, 2026 - 12:56 MDT

Investigating

ISS is aware of and currently investigating a service disruption.

What service is affected: Anchutz campus networks in various building may be unavailable. ISS is working to determine which specific locations/building affected.

What is the issue: Power outages causing switches and other hardware to go offline. This is affecting multiple buildings across campus and on-campus users can expect to see sporadic network issues as long as the current power issue persists.

Who is impacted: Users trying to access network resources.

Workarounds (if any): None at this time.

Thank you for your patience while our team works on identifying the cause and resolving it as quickly as possible.

Incident:
Posted Jul 05, 2026 - 10:53 MDT
This incident affects: Network Services (CU Anschutz).