Call Center Degraded Service

Incident Report for CU Anschutz ISS and CU Denver OIT

Resolved

Call Center phone management services remain stable, and ISS personnel have not received any reports of new issues during the monitoring period. This incident has been resolved.
Posted May 08, 2026 - 16:14 MDT

Monitoring

A fix has been implemented and Call Center phone management services are now available. ISS personnel are monitoring the results.
Posted May 08, 2026 - 09:36 MDT

Investigating

Call Center phone management services may be unavailable for some users. Incoming calls to call centers are not impacted. ISS technical staff are currently investigating. Ticket 3062824.
Posted May 07, 2026 - 10:03 MDT
This incident affected: Telephone Services (CU Anschutz, CU Denver, Off-Site Location).