AWS Outage Creating Degraded Service for M365

Incident Report for CU Anschutz ISS and CU Denver OIT

Resolved

This vendor outage/degradation of service appears to be resolved.
Posted Oct 30, 2025 - 11:57 MDT

Monitoring

This vendor outage/degradation of service appears to be resolved.
Posted Oct 29, 2025 - 15:24 MDT

Identified

The campus is currently experiencing degraded performance with Microsoft 365 services including Exchange Online, Microsoft 365 suite, Copilot, Microsoft Intune, Microsoft Purview, due to a widespread AWS outage.
Posted Oct 29, 2025 - 11:19 MDT
This incident affected: Email and Other Systems and Services.