Service Disruption: Calling Center Queues Unavailable

Incident Report for CU Anschutz ISS and CU Denver OIT

Resolved

ISS has determined that service has been fully restored.

What service was affected: Finesse (Calling Center Software) queues for calling center agents and supervisors managing queues.

What is the resolution: Technical teams performed troubleshooting and testing and ensured full operational performance of the system.

If you are still experiencing service degradation after this resolution, please contact the Service Desk at 303-724-4357.

Incident:
Posted Jul 28, 2026 - 09:17 MDT

Monitoring

ISS has identified the cause of the service disruption.

What service is affected: Finesse (Calling Center Software) queues for calling center agents and supervisors managing queues.

What fix has been applied: Continued investigation has not shown replicable impacts on other agents/queues. Service appears to be working properly. After hours work will finalize and address other potential issues.

Workarounds (if any): None known.

ISS will continue to monitor the service for full stability and service restoration.

Incident: 3078337
Posted Jul 27, 2026 - 09:05 MDT

Investigating

ISS is aware of and currently investigating a service disruption.

What service is affected: Finesse (Calling Center Software) queues for calling center agents and supervisors managing queues.

What is the issue: Calling center agents are not able to look at their queues in the call center software. Calls are still flowing and agents are able to place calls

Who is impacted: Calling center agents and supervisors using the Finesse software

Workarounds (if any): None known.

Thank you for your patience while our team works on identifying the cause and resolving it as quickly as possible.

Incident: 3078337
Posted Jul 27, 2026 - 08:35 MDT
This incident affected: Other Systems and Services.