School of Dental Medicine Call Center experiencing issues

Incident Report for CU Anschutz ISS and CU Denver OIT

Resolved

This incident has been resolved.
Posted Jun 02, 2026 - 16:16 MDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 02, 2026 - 14:12 MDT

Identified

Call Center users at School of Dental Medicine are experiencing issues logging into Cisco phones and Finesse.
Posted Jun 02, 2026 - 11:49 MDT
This incident affected: Telephone Services (CU Anschutz).