Email Delivery Delay to Some External Domains

Incident Report for CU Anschutz OIT | CU Denver OIT

Resolved

This incident has been resolved. Ticket 470046.
Posted Sep 04, 2025 - 10:00 MDT

Monitoring

Delivery delays have been resolved. ISS personnel will monitor the results. Ticket 470046.
Posted Sep 04, 2025 - 07:42 MDT

Update

ISS personnel are continuing observe successful delivery reports. Updates will be provided in the morning. Ticket 470046.
Posted Sep 03, 2025 - 17:14 MDT

Identified

Some users emailing an external email domain may experience a delivery delay or report of unsuccessful delivery. ISS personnel have identified the issue, implemented a configuration change, and are now seeing successful delivery reports; however, it could take several hours for this issue to be resolved completely. Ticket 470046.
Posted Sep 03, 2025 - 11:12 MDT
This incident affected: Email.