ISS has applied a fix and restored service to CU Call Center software. ISS has contacted multiple user groups to verify restoration of services. Given the breadth of service interruptions caused by this incident, it will remain in a monitoring state for the near future while ISS stays alert fo an additional impacted services.
Posted Jul 10, 2025 - 13:54 MDT
Identified
All services appear to be functioning following efforts from 7/9/2025 except for Cisco Finesse (call center software). Call Center software is currently unavailable. ISS personnel have re-engaged with vendor support to address the issue.
Posted Jul 10, 2025 - 07:31 MDT
Update
All services appear to be functioning following efforts from 7/9/2025 except for Cisco Finesse (call center software). For service, all call center users should connect to https://amcuccx01.ucdenver.pvt/ We apologize for the inconvenience.
Posted Jul 10, 2025 - 02:33 MDT
Monitoring
ISS has identified the root cause of the issue and has addressed it across multiple systems. All account maintenance web pages, Redcap, and internal maintenance pages have been restored to service Cisco Call center software is still being affected and is scheduled for full restoration of services after working hours today. This incident will remain in a monitoring state as ISS personnel continue to investigate and address isolated issues as they are discovered.
Posted Jul 09, 2025 - 16:35 MDT
Investigating
ISS is experiencing an issue with new account setup, and password maintenance. In addition, Redcap and ISS internal documentation are not functioning as expected. ISS is investigating the issue.
Posted Jul 09, 2025 - 14:45 MDT
This incident affects: Telephone Services (CU Anschutz, CU Denver, Off-Site Location).