Sitefinity Editors Degraded Service

Incident Report for CU Anschutz ISS and CU Denver OIT

Resolved

Our vendor implemented a fix within their systems and we have verified site editing capabilities are functioning normally.
Posted Mar 02, 2026 - 19:12 MST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 02, 2026 - 15:11 MST

Investigating

Some users may be experiencing issues editing hosted webpages (through Sitefinity) due to service issues with that partner.
Posted Mar 02, 2026 - 14:38 MST
This incident affected: University Webpages (CU Anschutz, CU Denver).