Power Outage at Anchutz Medical Center

Incident Report for CU Anschutz ISS and CU Denver OIT

Resolved

This incident has been resolved.
Posted Jan 21, 2026 - 16:39 MST

Update

Education 2 South Building still having power issues. For more information visit https://www.cuanschutz.edu/police/anschutz-alerts
Posted Jan 21, 2026 - 06:17 MST

Monitoring

Excel has restored power. OIT is currently verifying that all devices, switches, routers, etc have come back online successfully.
Posted Jan 20, 2026 - 16:19 MST

Investigating

Reports of power outages at Campus Services building and School of Dental Medicine. Both are running on generators. It is not clear at the moment the cause or extent of these power issues
Posted Jan 20, 2026 - 14:43 MST
This incident affected: Other Systems and Services.