My.CU Campus Portal appears to be down

Incident Report for CU Anschutz ISS and CU Denver OIT

Resolved

Technical staff have implemented a resolution and tested the fix. Authentication services and the CU Portal have resumed normal operation. An incident report will be sent out in the next business day.
Posted Nov 15, 2025 - 17:48 MST

Update

Technical staff are investigating the issue and will communicate updates as they are known. Ticket# 487318
Posted Nov 15, 2025 - 14:25 MST

Investigating

We are currently investigating this issue.
Posted Nov 15, 2025 - 14:23 MST
This incident affected: Authentication Services.