DUO Phone Call Authentication Failure

Incident Report for CU Anschutz ISS and CU Denver OIT

Resolved

This incident has been resolved.
Posted Feb 23, 2026 - 11:42 MST

Investigating

Some users may experience sporadic issues with DUO Phone Call authentication. Other authentication methods (push and text) are working normally. Our provider is investigating and working to resolve.
Posted Feb 23, 2026 - 09:11 MST
This incident affected: Authentication Services.