Forgot Password site is experiencing problems
Incident Report for CU Anschutz OIT | CU Denver OIT
Resolved
This incident has been resolved.
Posted Jan 18, 2024 - 11:13 MST
Identified
The issue has been identified and a fix is being implemented.
Posted Jan 18, 2024 - 10:01 MST
Investigating
The password reset page at https://myaccount.ucdenver.edu/forgot-password is currently experiencing problems and unavailable.

As a workaround, users can change their password at this link https://passport.ucdenver.edu or contact the OIT Service Desk at 303-724-4357
Posted Jan 18, 2024 - 08:41 MST
This incident affected: Authentication Services.