Canvas: Blackboard Ally degraded performance

Incident Report for CU Anschutz ISS and CU Denver OIT

Resolved

This incident has been resolved.
Posted May 15, 2026 - 16:46 MDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 15, 2026 - 13:30 MDT

Identified

The issue has been identified and a fix is being implemented.
Posted May 15, 2026 - 11:05 MDT

Investigating

ISS teams are currently working with the vendor investigating degraded performance within the Blackboard Ally tool.
Posted May 15, 2026 - 10:46 MDT
This incident affected: Canvas.