Percipio by Skillsoft Unavailable

Incident Report for CU Anschutz ISS and CU Denver OIT

Resolved

This incident has been resolved.
Posted Jun 16, 2026 - 14:19 MDT

Monitoring

A fix has been implemented by the vendor and early testing indicates Percipio is fully operational. ISS will continue monitoring this tool.
Posted Jun 16, 2026 - 11:33 MDT

Investigating

University members are experiencing difficulty accessing Percipio by Skillsoft. ISS is engagied with the owner of this service to investigate the cause.
Posted Jun 16, 2026 - 10:36 MDT
This incident affected: Other Systems and Services.