Xcel power outage

Incident Report for CU Anschutz ISS and CU Denver OIT

Resolved

Power has been restored and all ISS services are green.
Posted Feb 01, 2026 - 20:23 MST

Monitoring

ISS is monitoring the power outage impacting the campus and surrounding areas.
Posted Feb 01, 2026 - 16:45 MST